SHOYAN BLOG

I am a pragmatic programmer.

そろそろlombokから卒業しようと考えています

便利なlombokですが、そろそろオワコンな感じがしています。理由はJavaのアップデートに追従することが困難になってきているからです。詳しくはLombok の Java9以降対応の記事に書いてあります。実際、Java9対応も遅かったですね。lombokを使い続けると、Javaのアップデートに追従していけなくなる未来が想像できます。

Spring Bootも2系からはlombokは使っていませんね。

lombokは便利ですが、別に無くてもなんとかなるライブラリなので、あえてこれから使う選択をする必要はないと思います。

よく読まれている記事

Comments